STATIC ROUTING commands for Router A
Router>enable
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RouterA
RouterA(config)#interface fa 0/0
RouterA(config-if)#ip address 10.0.0.1 255.0.0.0
RouterA(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterA(config-if)#exit
RouterA(config)#interface s 0/0
RouterA(config-if)#ip address 20.0.0.1 255.0.0.0
RouterA(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
RouterA(config-if)#clock rate 64000
RouterA(config-if)#exit
RouterA(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
RouterA(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 10.0.0.0/8 is directly connected, FastEthernet0/0
RouterA#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.1 YES manual up up
Serial0/0 20.0.0.1 YES manual down down
Serial0/1 unassigned YES manual administratively down down
RouterA#
-------------------------------------after RouterB configured-------------------------------------------------------
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
RouterA#ping 30.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 47/59/63 ms
RouterA#ping 30.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms
RouterA#
STATIC ROUTING commands for Router B
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RouterB
RouterB(config)#interface fa 0/0
RouterB(config-if)#ip address 30.0.0.1 255.0.0.0
RouterB(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterB(config-if)#exit
RouterB(config)#interface s 0/0
RouterB(config-if)#ip address 20.0.0.2 255.0.0.0
RouterB(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
RouterB(config-if)#clock rate 64000
RouterB(config-if)#exit
RouterB(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
RouterB(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S 10.0.0.0/8 [1/0] via 20.0.0.1
C 20.0.0.0/8 is directly connected, Serial0/0
C 30.0.0.0/8 is directly connected, FastEthernet0/0
RouterB#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 62/62/62 ms
RouterB#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/63 ms
RouterB#
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RouterA
RouterA(config)#interface fa 0/0
RouterA(config-if)#ip address 10.0.0.1 255.0.0.0
RouterA(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterA(config-if)#exit
RouterA(config)#interface s 0/0
RouterA(config-if)#ip address 20.0.0.1 255.0.0.0
RouterA(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
RouterA(config-if)#clock rate 64000
RouterA(config-if)#exit
RouterA(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
RouterA(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 10.0.0.0/8 is directly connected, FastEthernet0/0
RouterA#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.1 YES manual up up
Serial0/0 20.0.0.1 YES manual down down
Serial0/1 unassigned YES manual administratively down down
RouterA#
-------------------------------------after RouterB configured-------------------------------------------------------
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
RouterA#ping 30.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 47/59/63 ms
RouterA#ping 30.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms
RouterA#
STATIC ROUTING commands for Router B
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RouterB
RouterB(config)#interface fa 0/0
RouterB(config-if)#ip address 30.0.0.1 255.0.0.0
RouterB(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterB(config-if)#exit
RouterB(config)#interface s 0/0
RouterB(config-if)#ip address 20.0.0.2 255.0.0.0
RouterB(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
RouterB(config-if)#clock rate 64000
RouterB(config-if)#exit
RouterB(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
RouterB(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S 10.0.0.0/8 [1/0] via 20.0.0.1
C 20.0.0.0/8 is directly connected, Serial0/0
C 30.0.0.0/8 is directly connected, FastEthernet0/0
RouterB#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 62/62/62 ms
RouterB#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/63 ms
RouterB#
No comments:
Post a Comment