test me

Site Search:

Switch/Router Interfaces and Physical Ports

ICND1 and ICND2 break down

In this section, we will talk about the various interfaces and their corresponding physical ports on the cisco switches and routers.

Let's take a close look at the output of command "show running-config" running on a Cisco 3560-24PS multilayer switch:

Switch#show running-config
Building configuration...

Current configuration : 984 bytes
!
version 12.2
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip ssh version 1
!
port-channel load-balance src-mac
!
interface FastEthernet0/1!
interface FastEthernet0/2...omitted for clarity...!
interface FastEthernet0/23!
interface FastEthernet0/24
!
interface GigabitEthernet0/1!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end

-----------------

As shown above, the cisco switch have 24 FastEthernet interfaces, 2 GigabitEthernet interfaces, 1 VLAN interface, 1 console line and 5 vty lines.

For some types of interfaces, including FastEthernet interface, GigabitEthernet interface, Serial interface, and console line there is an one-to-one mapping between a specific interface and its corresponding physical port on the cisco device. The naming rule is type slot/port. For example, FastEthernet 0/1 interface can be mapped to the FastEthernet port (type) located in slot number 0 and port number 1, as circled in the following picture.


switch port 1
switch port 1

Other types of interfaces, however, are virtue, which means a interface don't always have a single port as its physical conterpart. For example, vlan 1 on a switch includes all the switch ports.  For another example, vty lines from number 0 through number 4 might all be assigned to one single FastEthernet port on a cisco device.

Let's run command "show running-config" on a 2621XM router.

Router#show running-config
Building configuration...

Current configuration : 502 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial0/2
 no ip address
 shutdown
!
interface Serial0/3
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end

---------------

Note that the router's interfaces are very similar to the switch's. We can map the FasterEthernet interfaces, Serial interfaces to the router's physical ports. As the following pictures show, this router have 2 slots. The left-side slot, slot number 1 is empty. The right-side slot, slot number 0 have two WIC-2T modules installed. These modules are changeable, that is, they can be replaced by other modules such as module WIC-1T.

router1 ports
router1 ports


The following picure is the detail view of slot 0. Don't forget the interface naming rule: "type slot/port".

router1 ports detail
router1 ports detail


The output of command "show running-config" looks slightly different on the cisco 2811 router:

Router#show running-config
Building configuration...

Current configuration : 455 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0 no ip address
 shutdown
!
interface Serial0/0/1 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end

-----------------------------------------

As the following pictures show, the 2811 router have 2 slots. The slot number 1 is empty. In slot number 2, we add one WIC-2T module.



router2 ports
router2 ports


Note that the naming rule for Serial port is "type router/slot/port", which explained what the extra 0/ mean.

router2 ports details
router2 ports details


Understanding the naming rule for ports on cisco devices is important, because this rule is also used in other commands such as "interface FastEthernet 0/1".

2 comments:

  1. The information you've provided on router interfaces and physical ports is surely going to help us alot. Thank a lot for sharing the same.

    Computer Enhancements NZ Ltd

    ReplyDelete
  2. This is truly an important piece of information given by you. Thank you so much for your post.

    Computer Enhancements NZ Ltd

    ReplyDelete